aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2021-01-29 23:06:25 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-02-12 17:08:02 +0800
commitc84698ef951b659dc77b63f113757b8746f86222 (patch)
tree857e6a4156d84c25eade67cbdfc041d911c11dd1
parent18e79929f17bca4cd9c1d4ef389a95d48cb24280 (diff)
downloadguix-c84698ef951b659dc77b63f113757b8746f86222.tar
guix-c84698ef951b659dc77b63f113757b8746f86222.tar.gz
gnu: Add xkeysnail.
* gnu/packages/xdisorg.scm (xkeysnail): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/xdisorg.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ac9a24e6ab..f0ebc49230 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -42,7 +42,7 @@
;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
@@ -328,6 +328,34 @@ application.")
(home-page "https://hluk.github.io/CopyQ/")
(license license:gpl3+)))
+(define-public xkeysnail
+ (package
+ (name "xkeysnail")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "xkeysnail" version))
+ (sha256
+ (base32
+ "1xyqp6yqxcwmxaqj86qcsiz0ly7bwr0a2w835myz909irhip3ngf"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ;tests need /dev/uinput
+ (inputs
+ `(("python-appdirs" ,python-appdirs)
+ ("python-evdev" ,python-evdev)
+ ("python-inotify-simple" ,python-inotify-simple)
+ ("python-xlib" ,python-xlib)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/mooz/xkeysnail")
+ (synopsis "Keyboard remapping tool for the X11 environment")
+ (description
+ "Xkeysnail is an X environment keyboard remapping tool, featuring
+high-level and flexible remapping mechanisms. It affects the low-level
+layers (evdev and uinput), making remapping work in almost all the places.")
+ (license license:gpl3+))) ; see README.md (no licence headers)
+
(define-public xclip
(package
(name "xclip")