aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2021-01-21 20:12:13 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-02-12 15:34:38 +0800
commitc5f5b356da9dfc62736afb63b2fb33ccb20959b4 (patch)
tree388f941929d00deb599dea5bae0d8780fcaa630d
parent8cd181e4d802af04ae76efad27420b9af5250dff (diff)
downloadguix-c5f5b356da9dfc62736afb63b2fb33ccb20959b4.tar
guix-c5f5b356da9dfc62736afb63b2fb33ccb20959b4.tar.gz
gnu: Add dwl.
* gnu/packages/wm.scm (dwl): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/wm.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 084822f2c7..a53af7282a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1258,6 +1259,50 @@ It is inspired by Xmonad and dwm. Its major features include:
project derived from the original Calm Window Manager.")
(license license:isc)))
+(define-public dwl
+ (package
+ (name "dwl")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/djpohly/dwl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18g2sx8cv54zl5iw5m9lzngrp6ra2pyp7c68qps2ava3brw9m0j2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (replace 'install ; no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "dwl" bin)))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("wlroots" ,wlroots)))
+ (home-page "https://github.com/djpohly/dwl")
+ (synopsis "Dynamic window manager for Wayland")
+ (description
+ "@command{dwm} is a compact, hackable compositor for Wayland based on
+wlroots. It is intended to fill the same space in the Wayland world that dwm
+does in X11, primarily in terms of philosophy, and secondarily in terms of
+functionality. Like dwm, dwl is easy to understand and hack on, due to a
+limited size and a few external dependencies. It is configurable via
+@file{config.h}.")
+ ;; LICENSE LICENSE.dwm LICENSE.tinywl
+ (license (list license:gpl3+ license:expat license:cc0))))
+
(define-public nitrogen
(package
(name "nitrogen")