aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-12 12:16:31 +0000
committer宋文武 <iyzsong@member.fsf.org>2021-02-13 10:38:13 +0800
commitbc7879cca6196905b3f1e2c9db6c674ef0b7f8ca (patch)
tree45f04c01d54fcfdc9efb0b8ded3f33c16941d2b5
parentd588cc8fa96e4a4bce56fac2ba3bbaaeaaed0047 (diff)
downloadguix-bc7879cca6196905b3f1e2c9db6c674ef0b7f8ca.tar
guix-bc7879cca6196905b3f1e2c9db6c674ef0b7f8ca.tar.gz
gnu: Add swappy.
* gnu/packages/image.scm (swappy): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/image.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 339bd7dcf2..28169b0295 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1820,6 +1821,36 @@ Features:
@end itemize\n")
(license license:gpl3+)))
+(define-public swappy
+ (package
+ (name "swappy")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jtheoof/swappy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14ac2jmnak7avcz0jhqjm30vk7pv3gq5aq5rdyh84k8c613kkicf"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)
+ ("glib" ,glib "bin"))) ; for 'glib-compile-resources'
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libnotify" ,libnotify)))
+ (home-page "https://github.com/jtheoof/swappy")
+ (synopsis "Grab and edit on the fly snapshots of a Wayland compositor")
+ (description
+ "@command{swappy} is a command-line utility to take and edit screenshots
+of Wayland desktops. Works great with grim, slurp and sway. But can easily
+work with other screen copy tools that can output a final PNG image to
+stdout.")
+ (license license:expat)))
+
(define-public gifsicle
(package
(name "gifsicle")