aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2021-01-19 19:25:41 +0100
committer宋文武 <iyzsong@member.fsf.org>2021-02-12 20:13:31 +0800
commitadf638065722b02ae672efa904aa34427f7c7238 (patch)
tree6e80d5623895e8bf68e8b85bbed14517f2c58b02
parent9d22c0ca3957b27b461191007814a4ee4fe44aff (diff)
downloadguix-adf638065722b02ae672efa904aa34427f7c7238.tar
guix-adf638065722b02ae672efa904aa34427f7c7238.tar.gz
gnu: python-invoke: Patch reference to bash.
* gnu/packages/python-xyz.scm (python-invoke)[arguments]: Patch the reference to 'bash' in the source. [inputs]: Add bash. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 783812eb03..3aa7516f01 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15267,7 +15267,19 @@ projects.")
(build-system python-build-system)
(arguments
;; XXX: Requires many dependencies that are not yet in Guix.
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-bash-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((bash (assoc-ref inputs "bash")))
+ (substitute* "invoke/config.py"
+ (("shell = \"/bin/bash\"")
+ (string-append "shell = \"" bash "/bin/bash\""))
+ )
+ #t))))))
+ (inputs
+ `(("bash" ,bash-minimal)))
(synopsis "Pythonic task execution")
(description
"Invoke is a Python task execution tool and library, drawing inspiration