aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-02-12 14:54:00 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-12 14:54:00 +0100
commit689b525db0a9f7dcc6e4cd5ba1ca4fbc06162ccb (patch)
tree4f72140f73ede468ff9a89f5a1565658206ae7e2
parent224582c54f3ff8f935c8e0fa56de4d5b0836d709 (diff)
downloadguix-689b525db0a9f7dcc6e4cd5ba1ca4fbc06162ccb.tar
guix-689b525db0a9f7dcc6e4cd5ba1ca4fbc06162ccb.tar.gz
gnu: flwrap: Use git repository.
The tarballs of older versions are not kept on the website. * gnu/packages/radio.scm (flwrap)[source]: Switch to git repository. [native-inputs]: Add autoconf and automake.
-rw-r--r--gnu/packages/radio.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 53c9d20ac0..55756c5e93 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -686,14 +686,18 @@ or USB connection.")
(version "1.3.5")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://www.w1hkj.com/files/flwrap/flwrap-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/fldigi/flwrap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0qqivqkkravcg7j45740xfky2q3k7czqpkj6y364qff424q2pppg"))))
+ (base32 "0xkhr82smfr7wpb9xl05wf7bz3vi2mr4xkcr2s8v6mblhgsdhqwg"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("fltk" ,fltk)
("libx11" ,libx11)