aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-02-12 14:08:27 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-12 14:24:53 +0100
commit65e9f13116edc58836cdbd1da60bfb81a3d58c82 (patch)
treea4c054aea03ce4e64e5d5f6a29829bb2425e4c1c
parent5207c5eb55282464a4732fe8b7df40b406ef38a3 (diff)
downloadguix-65e9f13116edc58836cdbd1da60bfb81a3d58c82.tar
guix-65e9f13116edc58836cdbd1da60bfb81a3d58c82.tar.gz
gnu: fldigi: Use git repository.
The tarballs of older versions are not kept on the website. Fixes <https://bugs.gnu.org/46461>. * gnu/packages/radio.scm (fldigi)[source]: Switch to git repository. [native-inputs]: Add autoconf, automake and gettext-minimal.
-rw-r--r--gnu/packages/radio.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 5ceae146ba..bb1135603a 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -40,6 +40,7 @@
#:use-module (gnu packages fltk)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages glib)
#:use-module (gnu packages gstreamer)
@@ -581,14 +582,19 @@ using GNU Radio and the Qt GUI toolkit.")
(version "4.1.17")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://www.w1hkj.com/files/fldigi/fldigi-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/fldigi/fldigi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1gzff60sn3h05279f9mdi1rkdws52m28shcil16911lvlq6ki13m"))))
+ (base32 "0qli67dmdf49nvvh0i66bvhys8p74ljdcck8i9ra5jsfncih2xn8"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("alsa-lib" ,alsa-lib)
("fltk" ,fltk)