aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2021-01-21 22:08:06 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-02-12 16:58:02 +0800
commit18e79929f17bca4cd9c1d4ef389a95d48cb24280 (patch)
tree49658ec75f310d8448f15625e7e2ff90438d4510
parent4e96ce4294d61b1550e2d7456926936e75cf4f60 (diff)
downloadguix-18e79929f17bca4cd9c1d4ef389a95d48cb24280.tar
guix-18e79929f17bca4cd9c1d4ef389a95d48cb24280.tar.gz
gnu: Add bpytop.
* gnu/packages/admin.scm (bpytop): New variable.
-rw-r--r--gnu/packages/admin.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a6cf633baa..d1df0b0473 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -576,6 +577,28 @@ application (for console or X terminals) and requires ncurses.")
memory, disks, network and processes.")
(license license:asl2.0)))
+(define-public bpytop
+ (package
+ (name "bpytop")
+ (version "1.0.61")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bpytop" version))
+ (sha256
+ (base32
+ "1p5jrrvj68v6cby8w7zms138xm1g5j2q58951lji0qlqr8145jjb"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-psutil" ,python-psutil)))
+ (home-page
+ "https://github.com/aristocratos/bpytop")
+ (synopsis "Resource monitor")
+ (description "Resource monitor that shows usage and stats for processor,
+memory, disks, network and processes. It's a Python port of
+@command{bashtop}.")
+ (license license:asl2.0)))
+
(define-public pies
(package
(name "pies")