aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-13 09:55:42 -0800
committerLeo Famulari <leo@famulari.name>2018-01-16 10:28:20 -0800
commite428b2c026f47ff8f1f3f4db93f8925af7159fad (patch)
tree895e55ef978fa9896e2b9539a667f28cdf8c875e
parent7c3f22e9c3311dcb27e9b8bd31c6fa6eb0a549d8 (diff)
downloadguix-e428b2c026f47ff8f1f3f4db93f8925af7159fad.tar
guix-e428b2c026f47ff8f1f3f4db93f8925af7159fad.tar.gz
gnu: python-libxml2: Inherit the replacement source of libxml2.
Previously, python-libxml2 would inherit the ungrafted libxml2, missing several patches on the libxml2 source code. * gnu/packages/xml.scm (python-libxml2, python2-libxml2): Use package/inherit.
-rw-r--r--gnu/packages/xml.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ce0d13a999..01a4353440 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -159,7 +159,7 @@ project (but it is usable outside of the Gnome platform).")
"libxml2-CVE-2017-15412.patch")))))))
(define-public python-libxml2
- (package (inherit libxml2)
+ (package/inherit libxml2
(name "python-libxml2")
(build-system python-build-system)
(arguments