aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-16 17:15:52 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-16 22:21:34 +0100
commit78724a5a91a81c6acea8e66c9b6ce86ce10bd110 (patch)
tree4309a59a00affe878f17fea2a6cf22988f9a9ceb
parent3ca1545b2107417228e7f351885d343fd9c32209 (diff)
downloadguix-78724a5a91a81c6acea8e66c9b6ce86ce10bd110.tar
guix-78724a5a91a81c6acea8e66c9b6ce86ce10bd110.tar.gz
gnu: haskell-check: Use HTTPS for hspec.github.io home pages.
* gnu/packages/haskell-check.scm (hspec-discover, ghc-hspec-core) (ghc-hspec-meta, ghc-hspec, ghc-hspec-contrib)[home-page]: Use HTTPS.
-rw-r--r--gnu/packages/haskell-check.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 45041c3698..d6d20218cf 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -583,7 +583,7 @@ JUnit tool for Java.")
(arguments `(#:haddock? #f)) ; Haddock phase fails because there are no
; documentation files.
(inputs `(("ghc-hspec-meta" ,ghc-hspec-meta)))
- (home-page "http://hspec.github.io/")
+ (home-page "https://hspec.github.io/")
(synopsis "Automatically discover and run Hspec tests")
(description "hspec-discover is a tool which automatically discovers and
runs Hspec tests.")
@@ -614,7 +614,7 @@ runs Hspec tests.")
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-hspec-expectations" ,ghc-hspec-expectations)
("ghc-silently" ,ghc-silently)))
- (home-page "http://hspec.github.io/")
+ (home-page "https://hspec.github.io/")
(synopsis "Testing framework for Haskell")
(description "This library exposes internal types and functions that can
be used to extend Hspec's functionality.")
@@ -644,7 +644,7 @@ be used to extend Hspec's functionality.")
("ghc-setenv" ,ghc-setenv)
("ghc-random" ,ghc-random)
("ghc-quickcheck-io" ,ghc-quickcheck-io)))
- (home-page "http://hspec.github.io/")
+ (home-page "https://hspec.github.io/")
(synopsis "Version of Hspec to test Hspec itself")
(description "This library provides a stable version of Hspec which is
used to test the in-development version of Hspec.")
@@ -673,7 +673,7 @@ used to test the in-development version of Hspec.")
("ghc-hunit" ,ghc-hunit)
("ghc-stringbuilder" ,ghc-stringbuilder)
("ghc-hspec-meta" ,ghc-hspec-meta)))
- (home-page "http://hspec.github.io/")
+ (home-page "https://hspec.github.io/")
(synopsis "Testing Framework for Haskell")
(description "This library provides the Hspec testing framework for
Haskell, inspired by the Ruby library RSpec.")
@@ -699,7 +699,7 @@ Haskell, inspired by the Ruby library RSpec.")
("ghc-quickcheck" ,ghc-quickcheck)))
(native-inputs
`(("hspec-discover" ,hspec-discover)))
- (home-page "http://hspec.github.io/")
+ (home-page "https://hspec.github.io/")
(synopsis "Contributed functionality for Hspec")
(description
"This package provides contributed Hspec extensions.")