aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-30 11:13:54 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-18 04:26:42 +0100
commit5d5ad3da881566c2cfe01bd70e6d759f241fc73a (patch)
treeedced929fb44bbf4884b3c22eba8615c1511eaaf
parentaf60a20034d5fb2c81afbb58fbb759a89798b4d4 (diff)
downloadguix-5d5ad3da881566c2cfe01bd70e6d759f241fc73a.tar
guix-5d5ad3da881566c2cfe01bd70e6d759f241fc73a.tar.gz
gnu: Add sl.
* gnu/packages/toys.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/toys.scm65
2 files changed, 66 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5d43fac5ad..b78fb9bae9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -346,6 +346,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/python.scm \
%D%/packages/python-crypto.scm \
%D%/packages/python-web.scm \
+ %D%/packages/toys.scm \
%D%/packages/tryton.scm \
%D%/packages/qt.scm \
%D%/packages/ragel.scm \
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
new file mode 100644
index 0000000000..05e1dab983
--- /dev/null
+++ b/gnu/packages/toys.scm
@@ -0,0 +1,65 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages toys)
+ #:use-module (gnu packages ncurses)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public sl
+ (package
+ (name "sl")
+ (version "5.02")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mtoyoda/" name
+ "/archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fjnnnxxq7zh9bm3yzbj84fgap0rhblxi2m10br83747gxsrcn8y"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (delete 'check) ; no tests
+ (replace 'install ; no ‘make install’ target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man (string-append out "/share/man"))
+ (man1 (string-append man "/man1"))
+ (man1-ja (string-append man "/ja/man1")))
+ (install-file "sl" bin)
+ (install-file "sl.1" man1)
+ (mkdir-p man1-ja)
+ (copy-file "sl.1.ja" (string-append man1-ja "/sl.1"))
+ #t))))))
+ (home-page "http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html")
+ (synopsis "Joke command to correct typing \"sl\" by mistake")
+ (description
+ "@dfn{SL} (for Steam Locomotive) displays one of several animated trains
+on the text terminal. It serves no useful purpose but to discourage mistakenly
+typing @command{sl} instead of @command{ls}.")
+ (license (license:non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution."))))