aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-01-14 20:13:13 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-01-16 19:09:58 -0500
commit44e4a621640b6495c816e9556613b074033c16f2 (patch)
tree7c8408acef82b62b2637fd4ad0bf9e0098efd4d9
parent093332e5eaf7a23df40d4be1e94926ebb3e8aa31 (diff)
downloadguix-44e4a621640b6495c816e9556613b074033c16f2.tar
guix-44e4a621640b6495c816e9556613b074033c16f2.tar.gz
gnu: Add python-shapely and python2-shapely.
* gnu/packages/python.scm (python-shapely, python2-shapely): New variables.
-rw-r--r--gnu/packages/python.scm49
1 files changed, 48 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 05d1314fe9..a131d52645 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -41,7 +41,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2017, 2018 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
@@ -76,6 +76,7 @@
#:use-module (gnu packages file)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages geo)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -470,6 +471,52 @@ pidof, tty, taskset, pmap.")
(define-public python2-psutil
(package-with-python2 python-psutil))
+(define-public python-shapely
+ (package
+ (name "python-shapely")
+ (version "1.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Shapely" version))
+ (sha256
+ (base32
+ "0svc58dzcw9gj92b4sgq35sdxkf85z0qwlzxarkzq4bp3h8jy58l"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)))
+ (inputs
+ `(("geos" ,geos)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-geos-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((geos (assoc-ref inputs "geos"))
+ (glibc (assoc-ref inputs ,(if (%current-target-system)
+ "cross-libc" "libc"))))
+ (substitute* "shapely/geos.py"
+ (("_lgeos = load_dll\\('geos_c', fallbacks=.*\\)")
+ (string-append "_lgeos = load_dll('geos_c', fallbacks=['"
+ geos "/lib/libgeos_c.so'])"))
+ (("free = load_dll\\('c'\\)\\.free")
+ (string-append "free = load_dll('c', fallbacks=['"
+ glibc "/lib/libc.so.6']).free"))))
+ #t)))))
+ (home-page "https://github.com/Toblerity/Shapely")
+ (synopsis "Library for the manipulation and analysis of geometric objects")
+ (description "Shapely is a Python package for manipulation and analysis of
+planar geometric objects. It is based on the @code{GEOS} library.")
+ (license license:bsd-3)))
+
+(define-public python2-shapely
+ (package-with-python2 python-shapely))
+
(define-public python-clyent
(package
(name "python-clyent")