aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-16 17:13:31 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-16 22:21:34 +0100
commit3ca1545b2107417228e7f351885d343fd9c32209 (patch)
tree525b5bab378cf83f9872c6454a037d913f388da8
parent7ea7eb2248cf8cc48ab92c3ea747252107e6e576 (diff)
downloadguix-3ca1545b2107417228e7f351885d343fd9c32209.tar
guix-3ca1545b2107417228e7f351885d343fd9c32209.tar.gz
gnu: python: Use HTTPS for ipython.org home pages.
* gnu/packages/python.scm (python-ipython-genutils, python-traitlets) (python-ipykernel, python-ipython, python-widgetsnbextension) (python-ipywidgets)[home-page]: Use HTTPS.
-rw-r--r--gnu/packages/python.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0a7ca2e77a..05d1314fe9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4255,7 +4255,7 @@ standard library.")
(base32 "19l2pp1c64ansr89l3cqh19jdi2ixhssdzx0vz4n6r52a6i281is"))))
(build-system python-build-system)
(arguments `(#:tests? #f)) ; no tests
- (home-page "http://ipython.org")
+ (home-page "https://ipython.org")
(synopsis "Vestigial utilities from IPython")
(description
"This package provides retired utilities from IPython. No packages
@@ -4292,7 +4292,7 @@ away.")
(native-inputs
`(("python-mock" ,python-mock)
("python-nose" ,python-nose)))
- (home-page "http://ipython.org")
+ (home-page "https://ipython.org")
(synopsis "Configuration system for Python applications")
(description
"Traitlets is a framework that lets Python classes have attributes with
@@ -4380,7 +4380,7 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(propagated-inputs
;; imported at runtime during connect
`(("python-jupyter-client" ,python-jupyter-client)))
- (home-page "http://ipython.org")
+ (home-page "https://ipython.org")
(synopsis "IPython Kernel for Jupyter")
(description
"This package provides the IPython kernel for Jupyter.")
@@ -4526,7 +4526,7 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
(substitute* "./IPython/core/tests/test_magic.py"
(("def test_dirops\\(\\):" all)
(string-append "@dec.skipif(True)\n" all))))))))
- (home-page "http://ipython.org")
+ (home-page "https://ipython.org")
(synopsis "IPython is a tool for interactive computing in Python")
(description
"IPython provides a rich architecture for interactive computing with:
@@ -6437,7 +6437,7 @@ interactive computing.")
(native-inputs
`(("python-certifi" ,python-certifi)
("python-nose" ,python-nose)))
- (home-page "http://ipython.org")
+ (home-page "https://ipython.org")
(synopsis "IPython HTML widgets for Jupyter")
(description "This package provides interactive HTML widgets for Jupyter
notebooks.")
@@ -6465,7 +6465,7 @@ notebooks.")
("python-ipython" ,python-ipython)
("python-traitlets" ,python-traitlets)
("python-widgetsnbextension" ,python-widgetsnbextension)))
- (home-page "http://ipython.org")
+ (home-page "https://ipython.org")
(synopsis "IPython HTML widgets for Jupyter")
(description "Ipywidgets are interactive HTML widgets for Jupyter
notebooks and the IPython kernel. Notebooks come alive when interactive