aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2022-09-01 14:55:47 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-09-01 17:42:36 +0200
commitea87b4e98a8d7dd6f5894ef231fa1b7033363f8d (patch)
treec03be7207663676a4710d9e517330cc5286fd796
parent13f53335ef62c4c68789e9255794a274b3beb6e4 (diff)
downloadguix-ea87b4e98a8d7dd6f5894ef231fa1b7033363f8d.tar
guix-ea87b4e98a8d7dd6f5894ef231fa1b7033363f8d.tar.gz
gnu: pipewire-0.3: Update to 0.3.56.
* gnu/packages/linux.scm (pipewire-0.3): Update it. [arguments]: Restore the shrink-runpath phase, as validate-runpath passes now. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 01fb79bf08..a685938ff9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8720,7 +8720,7 @@ of Linux application development.")
(package
(inherit pipewire)
(name "pipewire")
- (version "0.3.43")
+ (version "0.3.56")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8729,17 +8729,13 @@ of Linux application development.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gp2h0sidapcqmnifl0iipdmbzb18bdh8zdi7pfywr9gsksh0cxy"))))
+ "066g4ri2k8pdflclvr2919f6x98gmqrqyj1xyiingw2nn2pwgcf1"))))
(arguments
'(#:configure-flags
(list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
"/lib/udev/rules.d")
"-Dsystemd=disabled"
- "-Dsession-managers=[]")
- #:phases
- (modify-phases %standard-phases
- ;; Skip shrink-runpath, otherwise validate-runpath fails.
- (delete 'shrink-runpath))))
+ "-Dsession-managers=[]")))
(inputs (modify-inputs (package-inputs pipewire)
(prepend avahi
bluez