aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-09-01 13:55:27 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-01 18:31:25 +0200
commitdfe848c9dce16070988e66dac40def29616eb4bd (patch)
tree0fea700b8ec062e41db7555ef24541e2f14a31c9
parent618699cb521c3ba8c896c24e313728076658b4c0 (diff)
downloadguix-dfe848c9dce16070988e66dac40def29616eb4bd.tar
guix-dfe848c9dce16070988e66dac40def29616eb4bd.tar.gz
gnu: ilmbase: Switch to gexps.
* gnu/packages/graphics.scm (ilmbase)[arguments]: Use a gexp.
-rw-r--r--gnu/packages/graphics.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 931a558e8a..f1588bac8b 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2021, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
@@ -771,11 +771,11 @@ applications, including the \"half\" 16-bit floating-point type.")
(patches (search-patches "ilmbase-fix-tests.patch"))))
(build-system cmake-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'change-directory
- (lambda _
- (chdir "IlmBase")
- #t)))))
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "IlmBase")
+ #t)))))
(home-page "https://www.openexr.com/")
(synopsis "Utility C++ libraries for threads, maths, and exceptions")
(description