aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaiju HIGASHI <higashi@taiju.info>2022-09-02 18:03:13 +0900
committerChristopher Baines <mail@cbaines.net>2022-09-02 19:22:32 +0100
commitb22b01297537a3fd6915f743db22c2d357fff5b0 (patch)
tree35fd36201240d127bce89885ffded4542833ec45
parent692fa4bc2e0897af9b1470419dd3bc889367f96f (diff)
downloadguix-b22b01297537a3fd6915f743db22c2d357fff5b0.tar
guix-b22b01297537a3fd6915f743db22c2d357fff5b0.tar.gz
gnu: Add ruby-latest-ruby.
* gnu/packages/ruby.scm (ruby-latest-ruby): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a2cafbf1f1..d658581ed0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2021 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Remco van 't Veer <remco@remworks.net>
+;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5398,6 +5399,24 @@ The output can be customized with a formatting system.")
(home-page "https://github.com/jfelchner/ruby-progressbar")
(license license:expat)))
+(define-public ruby-latest-ruby
+ (package
+ (name "ruby-latest-ruby")
+ (version "3.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "latest_ruby" version))
+ (sha256
+ (base32
+ "15rqwgxzpnkzdiz8m02jra0zq5sx0fiz61vkfrj1ls6slqfhnzqg"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; No Rakefile
+ (synopsis "Answers the question of what the latest Ruby version is")
+ (description "Knows about MRI, Rubinius, JRuby, MagLev and MacRuby.")
+ (home-page "https://github.com/kyrylo/latest_ruby")
+ (license license:zlib)))
+
(define-public ruby-pry
(package
(name "ruby-pry")