aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-09-04 08:21:39 +0300
committerMathieu Othacehe <othacehe@gnu.org>2022-09-04 17:01:14 +0200
commitae81cb69622e207e491618869d3452c0e68203d0 (patch)
treefe6ba98d4f9da6b22ad0ddf82d45f5c90d587113
parent77e3042aef6d8e519d016555464e466399318b4f (diff)
downloadguix-ae81cb69622e207e491618869d3452c0e68203d0.tar
guix-ae81cb69622e207e491618869d3452c0e68203d0.tar.gz
gnu: guile-ics: Update to 0.3.0.
* gnu/packages/guile-xyz.scm (guile-ics): Update to 0.3.0. [phases]: Remove "strip" phase. [propagated-inputs]: Add "guile-smc". Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 204d48dcb5..325252fbc6 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1733,28 +1733,30 @@ provides tight coupling to Guix.")
(define-public guile-ics
(package
(name "guile-ics")
- (version "0.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/artyom-poptsov/guile-ics")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "11wv6qk8xd4sd8s97mnw383p098ffivk0na4jii76r5wbmg1wd7q"))
- (modules '((guix build utils)))))
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/artyom-poptsov/guile-ics")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1526kdzcn0qvf5hpb4x5q01vb9mph9gfw24p81inqgjvy7a57lf9"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (delete 'strip))))
(native-inputs
(list autoconf
automake
texinfo
- ;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
- gettext-minimal
+ gettext-minimal ;Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
help2man
pkg-config))
(inputs (list guile-3.0 which))
- (propagated-inputs (list guile-lib))
+ (propagated-inputs (list guile-lib guile-smc))
(home-page "https://github.com/artyom-poptsov/guile-ics")
(synopsis "Guile parser library for the iCalendar format")
(description