aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTaiju HIGASHI <higashi@taiju.info>2022-09-02 18:03:14 +0900
committerChristopher Baines <mail@cbaines.net>2022-09-02 19:22:32 +0100
commit98d7ffcda683c052ea670ebb8ea3e1e29e7daa37 (patch)
tree7f6c65585b88ad0da25cc279082e02cf15ebbe73
parentb22b01297537a3fd6915f743db22c2d357fff5b0 (diff)
downloadguix-98d7ffcda683c052ea670ebb8ea3e1e29e7daa37.tar
guix-98d7ffcda683c052ea670ebb8ea3e1e29e7daa37.tar.gz
gnu: Add ruby-pry-doc.
* gnu/packages/ruby.scm (ruby-pry-doc): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d658581ed0..94c3bfeb6f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5440,6 +5440,29 @@ invocation, and source and documentation browsing.")
(home-page "https://cobaltbluemedia.com/pryrepl/")
(license license:expat)))
+(define-public ruby-pry-doc
+ (package
+ (name "ruby-pry-doc")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "pry-doc" version))
+ (sha256
+ (base32
+ "0wyvql6pb6m8jl8bsamabxhxhd86bnqblspaxzz05sl0fm2ynj0r"))))
+ (build-system ruby-build-system)
+ (propagated-inputs (list ruby-pry ruby-yard))
+ (native-inputs (list ruby-latest-ruby ruby-rspec ruby-rake)) ;for tests
+ (synopsis "Provides YARD and extended documentation support for Pry")
+ (description
+ "Pry Doc is a Pry REPL plugin. It provides extended documentation
+support for the REPL by means of improving the @code{show-doc} and
+@code{show-source} commands. With help of the plugin the commands are
+be able to display the source code and the docs of Ruby methods and
+classes implemented in C.")
+ (home-page "https://github.com/pry/pry-doc")
+ (license license:expat)))
+
(define-public ruby-single-cov
(package
(name "ruby-single-cov")