aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-03 10:07:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-09-03 10:09:34 +0200
commit91c31205537a7314eb45d71755fc8f63b80e004f (patch)
tree0170b4a08286bddb311db1db40e04f9e1b469ce9
parentf66cb7372f869e60d27665521f39a06f9170de88 (diff)
downloadguix-91c31205537a7314eb45d71755fc8f63b80e004f.tar
guix-91c31205537a7314eb45d71755fc8f63b80e004f.tar.gz
gnu: emacs-shell-command+: Update to 2.4.1.
* gnu/packages/emacs-xyz.scm (emacs-shell-command+): Update to 2.4.1.
-rw-r--r--gnu/packages/emacs-xyz.scm37
1 files changed, 17 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7f6cfb4e41..62b17607c1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30819,29 +30819,26 @@ rather excellent completion provided by both Bash and Zsh.")
(license license:gpl3+)))
(define-public emacs-shell-command+
- ;; XXX: Upstream did not tag last release. The commit below corresponds to
- ;; the exact version bump.
- (let ((commit "bf744c63bbd1e3bbb93407bd32d6da670b23e67e"))
- (package
- (name "emacs-shell-command+")
- (version "2.3.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~pkal/shell-command-plus")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0prlvcryq5ngrzn5f45rkw09wbr99v7nnwps2bjrjc3wvr2rp6h0"))))
- (build-system emacs-build-system)
- (home-page "http://elpa.gnu.org/packages/shell-command+.html")
- (synopsis "Extended Emacs @code{shell-command}")
- (description
- "Shell-command+ is a @code{shell-command} substitute that extends the
+ (package
+ (name "emacs-shell-command+")
+ (version "2.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~pkal/shell-command-plus")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14akj7pavfhch6ljwl26mhv7qczgmqn7mld62cf6mh4ghmhy3z4y"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/shell-command+.html")
+ (synopsis "Extended Emacs @code{shell-command}")
+ (description
+ "Shell-command+ is a @code{shell-command} substitute that extends the
regular Emacs command with several features. You can for example count all
the lines in a buffer with @code{> wc -l}, or delete all lower case letters in
the selected region with @code{| tr -d a-z}.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-shell-pop
(let ((commit "4b4394037940a890a313d715d203d9ead2d156a6")