aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-08-29 09:06:58 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-09-03 20:21:25 +0200
commit5cd7d7b3a27759fbaa990cbd81d8fbf4258691e0 (patch)
tree096f6c0043ef3b764ac5eda4e5b9257d3ce37399
parent5cf9b98d1cdd25ee44224f8256ea6f719b9aa0bd (diff)
downloadguix-5cd7d7b3a27759fbaa990cbd81d8fbf4258691e0.tar
guix-5cd7d7b3a27759fbaa990cbd81d8fbf4258691e0.tar.gz
gnu: Add ocaml-guile.
* gnu/packages/ocaml.scm (ocaml-guile): New variable.
-rw-r--r--gnu/packages/ocaml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0e8e5b2adc..2fd519ca41 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8741,3 +8741,36 @@ SHA384, SHA512, Blake2b, Blake2s and RIPEMD160.")
(description "This package allows you to produce, from a set of
bibliography files in BibTeX format, a bibliography in HTML format.")
(license license:gpl2)))
+
+(define-public ocaml-guile
+ (package
+ (name "ocaml-guile")
+ (version "1.0")
+ (home-page "https://github.com/gopiandcode/guile-ocaml")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yxdkrhrrbwvay5sn0p26rh3f11876k6kdharmpi4afxknml74ql"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (propagated-inputs
+ (list ocaml-sexplib
+ ocaml-ctypes
+ ocaml-stdio
+ ocaml-odoc))
+ (inputs (list guile-3.0 libffi))
+ (native-inputs
+ (list ocaml-odoc
+ pkg-config))
+ (synopsis "Bindings to GNU Guile Scheme for OCaml")
+ (description
+ "The OCaml guile library provides high-level OCaml bindings to GNU Guile
+3.0, supporting easy interop between OCaml and GNU Guile Scheme.")
+ (license license:gpl3+)))