aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2022-02-08 17:36:22 +1100
committerMarius Bakke <marius@gnu.org>2022-09-01 16:08:17 +0200
commit4f7f4e82e1f63f49216ee11dcfa67123ef940fcd (patch)
tree6a59eca73abedcc3c348785cd88eaa1760e4100a
parent2ebb0383a2d9015cb2fb69dce504dcb8dc0a9be3 (diff)
downloadguix-4f7f4e82e1f63f49216ee11dcfa67123ef940fcd.tar
guix-4f7f4e82e1f63f49216ee11dcfa67123ef940fcd.tar.gz
gnu: Add appstream-qt.
* gnu/packages/freedesktop.scm (appstream-qt): Add a build of appstream with Qt support. Co-authored-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/freedesktop.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 308f6fed3f..8866fe3a94 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -188,6 +188,20 @@ application-centers for distributions.")
(home-page "https://www.freedesktop.org/wiki/Distributions/AppStream/")
(license license:lgpl2.1+)))
+(define-public appstream-qt
+ (package/inherit appstream
+ (name "appstream-qt")
+ (native-inputs
+ (modify-inputs (package-native-inputs appstream)
+ (prepend qttools-5)))
+ (inputs
+ (modify-inputs (package-inputs appstream)
+ (prepend qtbase-5)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments appstream)
+ ((#:configure-flags flags #~'())
+ #~(append '("-Dqt=true") #$flags))))))
+
(define-public farstream
(package
(name "farstream")