aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-09-01 09:28:58 -0400
committerDavid Thompson <dthompson2@worcester.edu>2022-09-01 11:32:18 -0400
commit13f53335ef62c4c68789e9255794a274b3beb6e4 (patch)
treec5806e045d8d66eacb55eb41b088bd78f8180d6a
parentc053dfa52dc778eb3d965f58a85c435ae7fab0dd (diff)
downloadguix-13f53335ef62c4c68789e9255794a274b3beb6e4.tar
guix-13f53335ef62c4c68789e9255794a274b3beb6e4.tar.gz
gnu: Add python-plotille.
* gnu/packages/python-xyz.scm (python-plotille): New variable. Signed-off-by: David Thompson <davet@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1fa4fd7428..b058704172 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -743,6 +743,25 @@ variables into the markdown template")
Markdown. All extensions are found under the module namespace of pymdownx.")
(license license:expat)))
+(define-public python-plotille
+ (package
+ (name "python-plotille")
+ (version "4.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "plotille" version))
+ (sha256
+ (base32
+ "0fvsk6glxfphhqy405h05rj3v95jd1byl5hv2fyd5l31wln23shj"))))
+ (build-system python-build-system)
+ (native-inputs (list python-six))
+ (home-page "https://github.com/tammoippen/plotille")
+ (synopsis "Plot in the terminal using braille dots")
+ (description
+ "Plotille provides a figure class and graphing functions to create plots,
+scatter plots, histograms and heatmaps in the terminal using braille dots.")
+ (license license:expat)))
+
(define-public python-mdx-gh-links
(package
(name "python-mdx-gh-links")