aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHendursaga <hendursaga@aol.com>2022-08-13 16:12:12 -0400
committerLudovic Courtès <ludo@gnu.org>2022-09-02 18:16:52 +0200
commit038286b0acd2ed50c3a57b4aa52ff42d5fd33c12 (patch)
treeea0c0423d1533dafc1f13f3dcbf649ba87c29457
parent5c444a0208e049b646d0dc4f1675f1d07cdbe507 (diff)
downloadguix-038286b0acd2ed50c3a57b4aa52ff42d5fd33c12.tar
guix-038286b0acd2ed50c3a57b4aa52ff42d5fd33c12.tar.gz
gnu: hashcat: Update to 6.2.5.
* gnu/packages/password-utils.scm (hashcat): Update to 6.2.5. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/password-utils.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 0069fdd74c..e8c3feaeba 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1112,27 +1112,25 @@ your online accounts makes it necessary.")
(define-public hashcat
(package
(name "hashcat")
- (version "6.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hashcat.net/files/hashcat-"
- version ".tar.gz"))
- (sha256
- (base32
- "104z63m7lqbb0sdrxhf9yi15l4a9zwf9m6zs9dbb3gf0nfxl1h9r"))))
- (native-inputs
- (list opencl-headers))
+ (version "6.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://hashcat.net/files/hashcat-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0sc96xcsc20xd4fyby3i45nm9as3hl4nhk9snkvmk5l9mpbrjs3g"))))
+ (native-inputs (list opencl-headers))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ;no tests
+ '(#:tests? #f ;no tests
#:make-flags (list (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure))))
(home-page "https://hashcat.net/hashcat/")
(synopsis "Advanced password recovery utility")
- (description "Hashcat is an password recovery utility, supporting five
+ (description
+ "Hashcat is an password recovery utility, supporting five
unique modes of attack for over 200 highly-optimized hashing algorithms.
Hashcat currently supports CPUs, GPUs, and other hardware accelerators on
Linux, Windows, and macOS, and has facilities to help enable distributed