aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-24 04:04:05 +0100
committerChristopher Baines <mail@cbaines.net>2021-03-31 08:15:27 +0100
commitf92e8e5ed1c01ec87a88b1bb71a898da5f20fb8c (patch)
tree0f15db74d42451cad99ab7657c8a225e6128fea9
parentfa76e52d874549582a1e21e2ec2ca0b6b41362cb (diff)
downloadguix-f92e8e5ed1c01ec87a88b1bb71a898da5f20fb8c.tar
guix-f92e8e5ed1c01ec87a88b1bb71a898da5f20fb8c.tar.gz
gnu: Add emacs-julia-repl.
* gnu/packages/emacs-xyz.scm (emacs-julia-repl): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 52191f3ebc..92aa2e40b4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -95,6 +95,7 @@
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8736,6 +8737,29 @@ E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
programming language.")
(license license:expat)))
+(define-public emacs-julia-repl
+ (package
+ (name "emacs-julia-repl")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpapp/julia-repl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11vpqqnxqj9nxh8kccj4y6h3f8lib6jxnsk6vxc2j2fqw6alnafm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tpapp/julia-repl")
+ (synopsis "Minor mode for interacting with a Julia REPL")
+ (description "This package provides a minor mode for interacting with a
+Julia REPL running inside Emacs. The julia process is started in an ANSI
+terminal (term), which allows text formatting and colors, and interaction with
+the help system and the debugger. It is recommended that you use this minor
+mode with the package emacs-julia-mode.")
+ (license license:expat)))
+
(define-public emacs-smex
(package
(name "emacs-smex")