aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandr Vityazev <avityazev@posteo.org>2021-03-23 13:26:01 +0300
committerChristopher Baines <mail@cbaines.net>2021-03-29 20:06:07 +0100
commitce29fa76f4d96a530ccc4c3ce5f0085c491f964c (patch)
treeefcda9d2ad6ef1ee76dadcfe6194722c36928389
parentebeb018ca32c3da0dc820440b2da8d229f78946b (diff)
downloadguix-ce29fa76f4d96a530ccc4c3ce5f0085c491f964c.tar
guix-ce29fa76f4d96a530ccc4c3ce5f0085c491f964c.tar.gz
gnu: emacs-org-roam: Update to 1.2.3-0.8ad57b1.
* gnu/packages/emacs-xyz.scm (emacs-org-roam): Update to 1.2.3-0.8ad57b1. [propagated-inputs]: Replace emacs-org-ref with emacs-org and remove emacs-company. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/emacs-xyz.scm50
1 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ead2144b42..52191f3ebc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26566,34 +26566,36 @@ snippets for Emacs.")
(license license:expat))))
(define-public emacs-org-roam
- (package
- (name "emacs-org-roam")
- (version "1.2.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/org-roam/org-roam")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0n8c0yxqb62i39kn0d5x83s96vwc0nbg0sx5hplffnbkfbj88bba"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-company" ,emacs-company)
- ("emacs-dash" ,emacs-dash)
- ("emacs-emacsql-sqlite3" ,emacs-emacsql-sqlite3)
- ("emacs-f" ,emacs-f)
- ("emacs-org-ref" ,emacs-org-ref)
- ("emacs-s" ,emacs-s)))
- (home-page "https://github.com/org-roam/org-roam/")
- (synopsis "Non-hierarchical note-taking with Org mode")
- (description "Emacs Org Roam is a solution for taking non-hierarchical
+ (let ((commit "8ad57b121831eda8d226faa14ff2ba7ab652849c")
+ (revision "0")
+ (version "1.2.3"))
+ (package
+ (name "emacs-org-roam")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/org-roam/org-roam")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "162qhb6rkpl1n0l8yhnwgagsx56ykaj9lchsny1id5z1257kgw9w"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-emacsql-sqlite3" ,emacs-emacsql-sqlite3)
+ ("emacs-f" ,emacs-f)
+ ("emacs-org" ,emacs-org)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/org-roam/org-roam/")
+ (synopsis "Non-hierarchical note-taking with Org mode")
+ (description "Emacs Org Roam is a solution for taking non-hierarchical
notes with Org mode. Notes are captured without hierarchy and are connected
by tags. Notes can be found and created quickly. Org Roam should also work
as a plug-and-play solution for anyone already using Org mode for their
personal wiki.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-org-roam-bibtex
(package