aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-30 13:10:37 -0400
committerLeo Famulari <leo@famulari.name>2021-03-31 14:30:52 -0400
commit60dfd36fda23b619b969f3cde6b3dd238996e2b1 (patch)
tree0d1b393de714209152f0e4c5f5df0bc431231b53
parentc891799bc7945f44490fc51d81d9115c30352662 (diff)
downloadguix-60dfd36fda23b619b969f3cde6b3dd238996e2b1.tar
guix-60dfd36fda23b619b969f3cde6b3dd238996e2b1.tar.gz
gnu: linux-libre 5.10: Update to 5.10.27.
* gnu/packages/linux.scm (linux-libre-5.10-version): Update to 5.10.27. (linux-libre-5.10-pristine-source): Update hash. * gnu/packages/aux-files/linux-libre/5.10-x86_64.conf: Update for linux-libre@5.10.27.
-rw-r--r--gnu/packages/aux-files/linux-libre/5.10-x86_64.conf2
-rw-r--r--gnu/packages/linux.scm4
2 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
index 4836307163..189e4e16b4 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
@@ -8146,7 +8146,7 @@ CONFIG_HYPERV_BALLOON=m
#
CONFIG_XEN_BALLOON=y
CONFIG_XEN_BALLOON_MEMORY_HOTPLUG=y
-CONFIG_XEN_BALLOON_MEMORY_HOTPLUG_LIMIT=512
+CONFIG_XEN_MEMORY_HOTPLUG_LIMIT=512
CONFIG_XEN_SCRUB_PAGES_DEFAULT=y
CONFIG_XEN_DEV_EVTCHN=m
CONFIG_XEN_BACKEND=y
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 77980b9980..f22b421b61 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -370,7 +370,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.10-version "5.10.26")
+(define-public linux-libre-5.10-version "5.10.27")
(define deblob-scripts-5.10
(linux-libre-deblob-scripts
linux-libre-5.10-version
@@ -378,7 +378,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "0hh27ccqimagr3aij7ygwikxw66y63sqwd0xlf49bhpjd090r9a7")))
(define-public linux-libre-5.10-pristine-source
(let ((version linux-libre-5.10-version)
- (hash (base32 "10hlc020imxxh71nvxhnnmd66bcxndfyi78v7wv7y5mcy4rjhlzw")))
+ (hash (base32 "1nb95ll66kxiz702gs903n3gy5ialz8cin58l19rqaai55kck7fr")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.10)))