aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:05:15 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:22 +0200
commit568cebc2583bc909b6ce3ed8fc53119d083f3864 (patch)
tree123ad6d63dd49864d787225aa994a518f6fb2af9
parent57e034d568226b83974de817f8f09c3ba3ea2360 (diff)
downloadguix-568cebc2583bc909b6ce3ed8fc53119d083f3864.tar
guix-568cebc2583bc909b6ce3ed8fc53119d083f3864.tar.gz
gnu: Add julia-zygoterules.
* gnu/packages/julia-xyz.scm (julia-zygoterules): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9a414fc739..af8b41e82b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1199,3 +1199,25 @@ working with @acronym{URIs,Uniform Resource Identifiers}, as defined in RFC
(description "This package supports SI units and also many other unit
system.")
(license license:expat)))
+
+(define-public julia-zygoterules
+ (package
+ (name "julia-zygoterules")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FluxML/ZygoteRules.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07i2mf6rr5b8i6l82qgwl5arsb5pwyyzyfasgnszhdqllk9501bs"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-macrotools" ,julia-macrotools)))
+ (home-page "https://github.com/FluxML/ZygoteRules.jl")
+ (synopsis "Add minimal custom gradients to Zygote")
+ (description "Minimal package which enables to add custom gradients to
+Zygote, without depending on Zygote itself.")
+ (license license:expat)))