aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:05:11 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:22 +0200
commit3d98a16ab4d4f35211d79f25bb46bf74629c1408 (patch)
tree0b359c028e2090ccbc65df661e76689054ed087d
parent73052c70051cdbf54af9d88aac0b1a821c10b901 (diff)
downloadguix-3d98a16ab4d4f35211d79f25bb46bf74629c1408.tar
guix-3d98a16ab4d4f35211d79f25bb46bf74629c1408.tar.gz
gnu: Add julia-specialfunctions.
* gnu/packages/julia-xyz.scm (julia-specialfunctions): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index d99eadcfd4..4bd5a1f9a3 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1004,6 +1004,33 @@ high-order accuracy, assuming that @code{f(x0+h)} has a Taylor series or some
other power series in @code{h}.")
(license license:expat)))
+(define-public julia-specialfunctions
+ (package
+ (name "julia-specialfunctions")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaMath/SpecialFunctions.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rfhrrkzi3ils7fklbn35ki1yp5x88fi71qknfwqyw4pk8cf8p80"))))
+ (build-system julia-build-system)
+ (inputs
+ `(("julia-chainrulestestutils" ,julia-chainrulestestutils)))
+ (propagated-inputs
+ `(("julia-chainrulescore" ,julia-chainrulescore)
+ ("julia-openspecfun-jll" ,julia-openspecfun-jll)))
+ (home-page "https://github.com/JuliaMath/SpecialFunctions.jl")
+ (synopsis "Special mathematical functions")
+ (description "This package provides special mathematical functions,
+including Bessel, Hankel, Airy, error, Dawson, exponential (or sine and
+cosine) integrals, eta, zeta, digamma, inverse digamma, trigamma, and
+polygamma functions.")
+ (license license:expat)))
+
(define-public julia-staticarrays
(package
(name "julia-staticarrays")