aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-10-26 22:01:45 -0400
committerLudovic Courtès <ludo@gnu.org>2021-01-31 21:49:58 +0100
commit8d2465fcfef96552517bef7d182a04255d5707c2 (patch)
tree538f0323a9880e6448293dd344691cbf691637a3
parent13a7d2a538b00aa0a8cf9b999f1a4ff3e5959af9 (diff)
downloadguix-8d2465fcfef96552517bef7d182a04255d5707c2.tar
guix-8d2465fcfef96552517bef7d182a04255d5707c2.tar.gz
gnu: emacs: Make strip-double-wrap more robust
* gnu/packages/emacs.scm (emacs) [strip-double-wrap]: Use regex to find emacs executable. This works even when the version is changed by package transformations (ex: version=git.master) Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ca14584ada..5cca2bc9f7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <mhw@netris.org>
@@ -195,17 +195,11 @@
(lambda* (#:key outputs #:allow-other-keys)
;; Directly copy emacs-X.Y to emacs, so that it is not wrapped
;; twice. This also fixes a minor issue, where WMs would not be
- ;; able to track emacs back to emacs.desktop. The version is
- ;; accessed using using THIS-PACKAGE so it "just works" for
- ;; inherited Emacs packages of different versions.
+ ;; able to track emacs back to emacs.desktop.
(with-directory-excursion (assoc-ref outputs "out")
- (copy-file (string-append
- "bin/emacs-"
- ,(let ((this-version (package-version this-package)))
- (or (false-if-exception
- (version-major+minor+point this-version))
- (version-major+minor this-version))))
- "bin/emacs")
+ (copy-file
+ (car (find-files "bin" "^emacs-([0-9]+\\.)+[0-9]+$"))
+ "bin/emacs")
#t)))
(add-before 'reset-gzip-timestamps 'make-compressed-files-writable
;; The 'reset-gzip-timestamps phase will throw a permission error