aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-02-01 12:37:03 +0100
committerLudovic Courtès <ludo@gnu.org>2021-02-01 12:51:03 +0100
commit37e997bc7867901dc5eaf9060358dfddacae8dd6 (patch)
tree0f9a5cd992f78816cd2829ecd58ea55130263996
parent221fddd2e2495b1405daf1b34e9f52d6ad19cbbf (diff)
downloadguix-37e997bc7867901dc5eaf9060358dfddacae8dd6.tar
guix-37e997bc7867901dc5eaf9060358dfddacae8dd6.tar.gz
gnu: rdma-core: Remove "-DIOCTL_MODE=write" configure flag.
Fixes <https://bugs.gnu.org/46229>. This flag was added in commit 2b14c60d3870e74f620775ec8dd64634ff874dc7. It is apparently no longer needed. Worse, it now causes segfaults when used with Omni-Path devices, as reported in the bug above. * gnu/packages/linux.scm (rdma-core)[arguments]: Remove "-DIOCTL_MODE=write" from #:configure-flags.
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index da4a76605c..f22564a35b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5528,14 +5528,7 @@ The package provides additional NTFS tools.")
(string-append "-DRST2MAN_EXECUTABLE="
(assoc-ref %build-inputs
"python-docutils")
- "/bin/rst2man.py")
-
- ;; On some configurations, the
- ;; IB_USER_MAD_REGISTER_AGENT ioctl, which is
- ;; used by default, would return ENODEV. To
- ;; avoid that, use 'write' instead of ioctls,
- ;; as suggested in 'CMakeList.txt'.
- "-DIOCTL_MODE=write")
+ "/bin/rst2man.py"))
#:phases
(modify-phases %standard-phases
(replace 'build