aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-26 00:02:01 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-02-01 12:07:01 -0500
commit35bb3d5ffd84778e1d97eeebc27711f8c35d045b (patch)
tree9a4b2389749a7b5a44c787dc79a1ebb627b9610b
parent877ab0266c69858a9d4554dffba89dc5300a0736 (diff)
downloadguix-35bb3d5ffd84778e1d97eeebc27711f8c35d045b.tar
guix-35bb3d5ffd84778e1d97eeebc27711f8c35d045b.tar.gz
gnu: inchi: Update to 1.06.
* gnu/packages/chemistry.scm (inchi): Update to 1.06. [source]: Use HTTPS. [native-inputs]: Update inchi-doc hash.
-rw-r--r--gnu/packages/chemistry.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index e7b061515b..69cfed454a 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -161,15 +161,16 @@ only with Python 2 and NumPy < 1.9.")
(define-public inchi
(package
(name "inchi")
- (version "1.05")
+ ;; Update the inchi-doc native input when updating inchi.
+ (version "1.06")
(source (origin
(method url-fetch)
- (uri (string-append "http://www.inchi-trust.org/download/"
+ (uri (string-append "https://www.inchi-trust.org/download/"
(string-join (string-split version #\.) "")
"/INCHI-1-SRC.zip"))
(sha256
(base32
- "081pcjx1z5jm23fs1pl2r3bccia0ww8wfkzcjpb7byhn7b513hsa"))
+ "1zbygqn0443p0gxwr4kx3m1bkqaj8x9hrpch3s41py7jq08f6x28"))
(file-name (string-append name "-" version ".zip"))))
(build-system gnu-build-system)
(arguments
@@ -222,7 +223,7 @@ only with Python 2 and NumPy < 1.9.")
"/INCHI-1-DOC.zip"))
(sha256
(base32
- "1id1qb2y4lwsiw91qr2yqpn6kxbwjwhjk0hb2rwk4fxhdqib6da6"))
+ "1kyda09i9p89xfq90ninwi7w13k1w3ljpl4gqdhpfhi5g8fgxx7f"))
(file-name (string-append name "-" version ".zip"))))))
(home-page "https://www.inchi-trust.org")
(synopsis "Utility for manipulating machine-readable chemical structures")