aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2021-01-29 11:09:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-31 17:00:29 +0100
commit232a10f006b95bf3950fb6c4a9ddc0dc6be75db7 (patch)
treed74c854c9671a5c47f2523bdf2f9bc603d4f73db
parentd6f79bc64d5bf51e9bfaaebfaf2aac5bf591acee (diff)
downloadguix-232a10f006b95bf3950fb6c4a9ddc0dc6be75db7.tar
guix-232a10f006b95bf3950fb6c4a9ddc0dc6be75db7.tar.gz
gnu: Add licenseheaders.
* gnu/packages/license.scm (licenseheaders): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/license.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index 369426768b..7b94c02558 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -205,3 +206,35 @@ tools that have a lot more features and functionality surrounding the analysis
and inspection of copyright and licenses in software projects. This one is
designed to be simple.")
(license (list asl2.0 gpl3+))))
+
+(define-public licenseheaders
+ (package
+ (name "licenseheaders")
+ (version "0.8.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "licenseheaders" version))
+ (sha256
+ (base32 "073xcm10gyg5kcxqmbsyaz9sr0slbdwgr0r9qanch0zl8i0z9259"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Reported upstream:
+ ;; <https://github.com/johann-petrak/licenseheaders/issues/47>.
+ (add-after 'unpack 'patch-code
+ (lambda _
+ (substitute* "licenseheaders.py"
+ (("\\\"filenames\\\": \\[\\\"CMakeLists.txt\\\"\\],")
+ "\"filenames\": [\"CMakeLists.txt\"], \n \"extensions\": [],"))
+ #t)))))
+ (propagated-inputs
+ `(("python-regex" ,python-regex)))
+ (home-page "http://github.com/johann-petrak/licenseheaders")
+ (synopsis "Add or change license headers for all files in a directory")
+ (description
+ "Licenseheaders is a Python 3 tool to update, change or add license
+headers to all files of any of the supported types in or below some
+directory.")
+ (license expat)))