aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-01-26 00:38:25 -0500
committerKei Kebreau <kkebreau@posteo.net>2021-02-01 12:07:01 -0500
commit1f1c525ac939eefbb433450693aef08fc252e62e (patch)
tree269bb0b1006d12f7c488e09409cd5d00fcb5ced3
parent35bb3d5ffd84778e1d97eeebc27711f8c35d045b (diff)
downloadguix-1f1c525ac939eefbb433450693aef08fc252e62e.tar
guix-1f1c525ac939eefbb433450693aef08fc252e62e.tar.gz
gnu: openbabel: Update to 3.1.1.
* gnu/packages/chemistry.scm (openbabel): Update to 3.1.1. [source]: Update URI. [arguments]: Temporarily skip tests on i686-linux.
-rw-r--r--gnu/packages/chemistry.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 69cfed454a..4b0e719959 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -522,19 +522,23 @@ usual algorithms you expect from a modern molecular dynamics implementation.")
(define-public openbabel
(package
(name "openbabel")
- (version "2.4.1")
+ (version "3.1.1")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/" name "/" name "/"
- version "/" name "-" version ".tar.gz"))
+ (uri (string-append "https://github.com/openbabel/openbabel/"
+ "releases/download/openbabel-"
+ (string-replace-substring version "." "-")
+ "/openbabel-" version "-source.tar.bz2"))
(sha256
(base32
- "1z3d6xm70dpfikhwdnbzc66j2l49vq105ch041wivrfz5ic3ch90"))
- (patches
- (search-patches "openbabel-fix-crash-on-nwchem-output.patch"))))
+ "0s0f4zib8vshfaywsr5bjjz55jwsg6yiz2qw4i5jm8wysn0q7v56"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags
+ `(;; FIXME: Disable tests on i686 to work around
+ ;; https://github.com/openbabel/openbabel/issues/2041.
+ #:tests? ,(or (%current-target-system)
+ (not (string=? "i686-linux" (%current-system))))
+ #:configure-flags
(list "-DOPENBABEL_USE_SYSTEM_INCHI=ON"
(string-append "-DINCHI_LIBRARY="
(assoc-ref %build-inputs "inchi")