aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-05-28 10:30:38 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-31 18:13:08 +0200
commitec8a9892d12dcc016ec0e524cc475e74f0dbf280 (patch)
tree3680107cbd7ff9ac6499ce3a0d308f94770d50ee
parent73d854232fbdd38a59f1a514691f0411929b4adc (diff)
downloadguix-ec8a9892d12dcc016ec0e524cc475e74f0dbf280.tar
guix-ec8a9892d12dcc016ec0e524cc475e74f0dbf280.tar.gz
gnu: Add python-bigfloat.
* gnu/packages/python.scm (python-bigfloat, python2-bigfloat): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 39a367aec8..0cdf82594d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5155,6 +5155,29 @@ more advanced mathematics.")
(define-public python2-mpmath
(package-with-python2 python-mpmath))
+(define-public python-bigfloat
+ (package
+ (name "python-bigfloat")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bigfloat" version))
+ (sha256
+ (base32 "0xd7q4l7v0f463diznjv4k9wlaks80pn9drdqmfifi7zx8qvybi6"))))
+ (build-system python-build-system)
+ (inputs
+ `(("mpfr" ,mpfr)))
+ (home-page "https://github.com/mdickinson/bigfloat")
+ (synopsis "Arbitrary precision floating-point arithmetic for Python")
+ (description
+ "This packages provides a Python interface to the MPFR library for
+multiprecision arithmetic.")
+ (license license:lgpl3+)))
+
+(define-public python2-bigfloat
+ (package-with-python2 python-bigfloat))
+
(define-public python-sympy
(package
(name "python-sympy")