aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-02-19 19:08:28 -0500
committerLudovic Courtès <ludo@gnu.org>2018-06-01 13:50:26 +0200
commita39e6faee9826ca473a0fdb8139a2fede25638d1 (patch)
tree866b6ccd8865027f207cf1df9da13476170e997d
parente3aae496f9965ba4dd6137bdefcbdfea42af7faa (diff)
downloadguix-a39e6faee9826ca473a0fdb8139a2fede25638d1.tar
guix-a39e6faee9826ca473a0fdb8139a2fede25638d1.tar.gz
gnu: Add ghc-ifelse.
* gnu/packages/haskell.scm (ghc-ifelse): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cb4ad7c0e8..d82f88e3ba 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3813,6 +3813,27 @@ with various performance characteristics.")
manipulating monad transformer stacks.")
(license license:bsd-3)))
+(define-public ghc-ifelse
+ (package
+ (name "ghc-ifelse")
+ (version "0.85")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "IfElse/IfElse-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kfx1bwfjczj93a8yqz1n8snqiq5655qgzwv1lrycry8wb1vzlwa"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-mtl" ,ghc-mtl)))
+ (home-page "http://hackage.haskell.org/package/IfElse")
+ (synopsis "Monadic control flow with anaphoric variants")
+ (description "This library provides functions for control flow inside of
+monads with anaphoric variants on @code{if} and @code{when} and a C-like
+@code{switch} function.")
+ (license license:bsd-3)))
+
(define-public ghc-monad-control
(package
(name "ghc-monad-control")