aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-31 00:17:55 -0400
committerMark H Weaver <mhw@netris.org>2018-05-31 00:23:41 -0400
commit88a3465e4a467be92729fc37d8bda0155bbf5c52 (patch)
tree656219d066c37b6d197012d9ba0228785305be6c
parent706d6190cabead6885d16cb2d89cd89f1a216229 (diff)
downloadguix-88a3465e4a467be92729fc37d8bda0155bbf5c52.tar
guix-88a3465e4a467be92729fc37d8bda0155bbf5c52.tar.gz
gnu: linux-libre: Revert bad upstream patch in 4.14/4.9/4.4 kernels.
Apply the 1-line revert from upstream that was the sole fix in 4.14.47, 4.9.105, and 4.4.135. Here we cherry-pick the patch until the corresponding linux-libre versions are released. * gnu/packages/linux.scm (linux-libre-4.14, linux-libre-4.9) (linux-libre-arm-generic-4.14, linux-libre-arm-omap2plus-4.14) (linux-libre-4.4): Add the patch.
-rw-r--r--gnu/packages/linux.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 72a25d5f30..98e92a62f8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -411,18 +411,45 @@ It has been modified to remove all non-free binary blobs.")
(make-linux-libre %linux-libre-4.14-version
%linux-libre-4.14-hash
'("x86_64-linux" "i686-linux" "armhf-linux")
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.9
(make-linux-libre "4.9.104"
"0b6y24vfsjhiv7qq7xqx7h9krc81c49dqh0189nm1lhfwciyir57"
%intel-compatible-systems
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.9.105 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=98d69fb3b175855cdd4c37d41a4b477a0860b1a0")
+ (sha256
+ (base32 "1r52fr0w94fgw7nfxrysjk0mljlnqwqsnl0cp84c1sly466i79dv"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.4
(make-linux-libre "4.4.134"
"137mklzyv56yhc48l5h5i0h01gm1q40x2a8nk51lwhbjv592xr8x"
%intel-compatible-systems
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.4.135 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=393e9b3c30d571c2f655aa24b0dee5be9ce249b5")
+ (sha256
+ (base32 "02wk036v525qwqs42ndqqj4mv8xfkpavibfg5ns6hkg2wc5a1jid"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.1
@@ -443,6 +470,15 @@ It has been modified to remove all non-free binary blobs.")
%linux-libre-4.14-hash
'("armhf-linux")
#:defconfig "multi_v7_defconfig"
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:extra-version "arm-generic"))
(define-public linux-libre-arm-omap2plus
@@ -457,6 +493,15 @@ It has been modified to remove all non-free binary blobs.")
%linux-libre-4.14-hash
'("armhf-linux")
#:defconfig "omap2plus_defconfig"
+ #:patches
+ (list %boot-logo-patch
+ (origin
+ ;; The sole fix in the 4.14.47 release.
+ (method url-fetch)
+ (uri "https://git.kernel.org/pub/scm/linux/kernel/\
+git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
+ (sha256
+ (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:extra-version "arm-omap2plus"))