aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-01 07:52:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-31 04:54:56 +0200
commit6c738fe9e7e6a95ce910f5a22e6f2c869075ec2d (patch)
treee6074a43abeaf306b7d06afd39fc37030395e221
parent4133914416f6e0d8cc4578d9ab5c1ad02c52fbde (diff)
downloadguix-6c738fe9e7e6a95ce910f5a22e6f2c869075ec2d.tar
guix-6c738fe9e7e6a95ce910f5a22e6f2c869075ec2d.tar.gz
gnu: khal: Use INVOKE.
* gnu/packages/calendar.scm (khal)[arguments]: Substitute INVOKE for SYSTEM* and explicitly return #t from phases where needed.
-rw-r--r--gnu/packages/calendar.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index d1aa9c256b..79cef99826 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -110,24 +111,24 @@ data units.")
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make installed package available for running the tests
(add-installed-pythonpath inputs outputs)
- (and
- (zero? (system* "make" "--directory=doc/" "man"))
- (install-file
- "doc/build/man/khal.1"
- (string-append (assoc-ref outputs "out") "/share/man/man1")))))
+ (invoke "make" "--directory=doc/" "man")
+ (install-file
+ "doc/build/man/khal.1"
+ (string-append (assoc-ref outputs "out") "/share/man/man1"))
+ #t))
(replace 'check
(lambda* (#:key inputs #:allow-other-keys)
;; The tests require us to choose a timezone.
(setenv "TZ"
(string-append (assoc-ref inputs "tzdata")
"/share/zoneinfo/Zulu"))
- (zero? (system* "py.test" "tests" "-k"
- (string-append
- ;; These tests are known to fail in when not
- ;; running in a TTY:
- ;; https://github.com/pimutils/khal/issues/683
- "not test_printics_read_from_stdin "
- "and not test_import_from_stdin"))))))))
+ (invoke "py.test" "tests" "-k"
+ (string-append
+ ;; These tests are known to fail in when not
+ ;; running in a TTY:
+ ;; https://github.com/pimutils/khal/issues/683
+ "not test_printics_read_from_stdin "
+ "and not test_import_from_stdin")))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)