aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-05-28 13:07:02 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-31 18:13:09 +0200
commit555ab0853bdd5e226e60c3243f571ef9832c8ac9 (patch)
tree708832c397be3e240b41dbc7cbcd61b1bffcfbd9
parent45dca193a46b04f9ed06dd1b60de9ed7f40a482a (diff)
downloadguix-555ab0853bdd5e226e60c3243f571ef9832c8ac9.tar
guix-555ab0853bdd5e226e60c3243f571ef9832c8ac9.tar.gz
gnu: Add emacs-zotxt.
* gnu/packages/emacs.scm (emacs-zotxt): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d2fa5eb225..90b7fb2cae 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10575,3 +10575,28 @@ be changed by customizing the appropriate variables.")
"Synchronize between events in Org-mode files and a CalDAV calendar.
This code is still alpha.")
(license license:gpl3+)))
+
+(define-public emacs-zotxt
+ (package
+ (name "emacs-zotxt")
+ (version "20180518")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/egh/zotxt-emacs/archive/"
+ "23a4a9f74a658222027d53a9a83cd4bcc583ca8b"
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1qlibaciqgsva6fc7vv9krssjq00bi880396jk7llbi3c52q9n1y"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-deferred" ,emacs-deferred)
+ ("emacs-request" ,emacs-request)))
+ (home-page "https://github.com/egh/zotxt-emacs")
+ (synopsis "Integrate Emacs with Zotero")
+ (description "This package provides two integration features between Emacs
+and the Zotero research assistant: Insertion of links to Zotero items into an
+Org-mode file, and citations of Zotero items in Pandoc Markdown files.")
+ (license license:gpl3+)))