aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-31 12:38:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-31 13:21:31 +0200
commit508dd24abe3659c8a819189d73000478c52320cf (patch)
treee8fa9a3cd30e0c623ee098f527bb90771a7a984c
parenteb0d599a676caaccdcb76430abfd484f11757cb8 (diff)
downloadguix-508dd24abe3659c8a819189d73000478c52320cf.tar
guix-508dd24abe3659c8a819189d73000478c52320cf.tar.gz
gnu: r-shiny: Update to 1.1.0.
* gnu/packages/web.scm (r-shiny): Update to 1.1.0. [source]: Fetch from git. [propagated-inputs]: Add r-crayon.
-rw-r--r--gnu/packages/web.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3b28e1f7fe..8b74bb4926 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5326,16 +5326,17 @@ snippets on @url{https://commandlinefu.com}.")
(define-public r-shiny
(package
(name "r-shiny")
- (version "1.0.3")
+ (version "1.1.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/rstudio/shiny/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rstudio/shiny.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0z2v2s4hd44mvzjn7r70549kdzkrrch9nxhp27r6x2cy6micizm3"))))
+ "041q2gzvzs13syfhbirmkik96asdji8dxnnbs63j7v1ks97hrvvz"))))
(build-system r-build-system)
(arguments
`(#:modules ((guix build r-build-system)
@@ -5400,7 +5401,8 @@ snippets on @url{https://commandlinefu.com}.")
"jquery.min.js")))))
#t)))))
(propagated-inputs
- `(("r-httpuv" ,r-httpuv)
+ `(("r-crayon" ,r-crayon)
+ ("r-httpuv" ,r-httpuv)
("r-mime" ,r-mime)
("r-jsonlite" ,r-jsonlite)
("r-xtable" ,r-xtable)