aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-05-28 10:42:37 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-31 18:13:08 +0200
commit45dca193a46b04f9ed06dd1b60de9ed7f40a482a (patch)
treee294a08bf7e853813a5b4b857ab039269fce9125
parentec8a9892d12dcc016ec0e524cc475e74f0dbf280 (diff)
downloadguix-45dca193a46b04f9ed06dd1b60de9ed7f40a482a.tar
guix-45dca193a46b04f9ed06dd1b60de9ed7f40a482a.tar.gz
gnu: Add emacs-org-caldav.
* gnu/packages/emacs.scm (emacs-org-caldav): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 48c9a6de2a..d2fa5eb225 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10551,3 +10551,27 @@ well as take screenshots and lock your screen. The package depends on the
availability of shell commands to do the hard work for us. These commands can
be changed by customizing the appropriate variables.")
(license license:gpl3+)))
+
+(define-public emacs-org-caldav
+ (package
+ (name "emacs-org-caldav")
+ (version "20180403")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/dengste/org-caldav/raw/"
+ "8d3492c27a09f437d2d94f2736c56d7652e87aa0"
+ "/org-caldav.el"))
+ (sha256
+ (base32
+ "1fh4gh68ddj0is99z2ccyh97v6psnyda61n2dsadzqhcxn51amlc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs `(("emacs-org" ,emacs-org)))
+ (home-page "https://github.com/dengste/org-caldav")
+ (synopsis
+ "Sync Org files with external calendars via the CalDAV protocol")
+ (description
+ "Synchronize between events in Org-mode files and a CalDAV calendar.
+This code is still alpha.")
+ (license license:gpl3+)))