aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-02-20 02:56:58 -0500
committerLudovic Courtès <ludo@gnu.org>2018-06-01 13:50:27 +0200
commit1ea3971992068944977cb031cc6b21018bdd001e (patch)
tree6d016dfbc3fcb2d05f598443b2eec4c63539aee9
parent6950a4507392bec54ad84378dd0a2c2904238f65 (diff)
downloadguix-1ea3971992068944977cb031cc6b21018bdd001e.tar
guix-1ea3971992068944977cb031cc6b21018bdd001e.tar.gz
gnu: ghc-psqueues: Allow building with newer versions of QuickCheck.
* gnu/packages/haskell.scm (ghc-psqueues)[arguments]: Add configure flag to allow newer versions of QuickCheck. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8427ce99a8..073f5b739f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7972,6 +7972,8 @@ bytestrings and their hexademical representation.")
(base32
"0n39s1i88j6s7vvsdhpbhcr3gpbwlzabwcc3nbd7nqb4kb4i0sls"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags (list "--allow-newer=QuickCheck")))
(inputs
`(("ghc-hashable" ,ghc-hashable)))
(native-inputs