aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-26 12:19:27 +0100
committerMarius Bakke <marius@gnu.org>2021-12-26 23:20:07 +0100
commitfabcdb446e7bd7f48fbdb64ca4fff5e2d3e0eef9 (patch)
tree6995d6e5a77fdc52ec79180a4b8772b6f76a4690
parent6fdf85154611e042307ca30ab2ac5fbde49597af (diff)
downloadguix-fabcdb446e7bd7f48fbdb64ca4fff5e2d3e0eef9.tar
guix-fabcdb446e7bd7f48fbdb64ca4fff5e2d3e0eef9.tar.gz
gnu: apostrophe: Don't reference the Python variable in arguments.
* gnu/packages/gnome.scm (apostrophe)[arguments]: Use THIS-PACKAGE-INPUT instead of accessing PYTHON directly. Remove trailing #t. [inputs]: Explicitly add PYTHON.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 57993b009f..8111f160c7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11930,8 +11930,7 @@ GTK+. It integrates well with the GNOME desktop environment.")
(add-after 'unpack 'patch-meson
(lambda _
(substitute* "build-aux/meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t))
+ (("gtk-update-icon-cache") "true"))))
(add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((prog (string-append (assoc-ref outputs "out")
@@ -11939,7 +11938,8 @@ GTK+. It integrates well with the GNOME desktop environment.")
(pylib (string-append (assoc-ref outputs "out")
"/lib/python"
,(version-major+minor
- (package-version python))
+ (package-version
+ (this-package-input "python")))
"/site-packages")))
(wrap-program prog
`("PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
@@ -11954,6 +11954,7 @@ GTK+. It integrates well with the GNOME desktop environment.")
gtk+
libhandy
pandoc
+ python
python-chardet
python-levenshtein
python-regex