aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-19 00:29:10 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 00:00:41 +0100
commitf6aa994a740ab4bd7395cd0fcb427a7cb3fa83f5 (patch)
tree4733278cfde227039609ce0c95cd4c2893d24517
parent51e26b297cda6fba1a842fbd63732bfa27878748 (diff)
downloadguix-f6aa994a740ab4bd7395cd0fcb427a7cb3fa83f5.tar
guix-f6aa994a740ab4bd7395cd0fcb427a7cb3fa83f5.tar.gz
gnu: Add python-pytest-celery.
* gnu/packages/python-check.scm (python-pytest-celery): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-check.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2d015fd6d2..d2aa1c328f 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1330,6 +1330,28 @@ fixtures for testing Tornado (version 5.0 or newer) apps and easy handling of
plain (undecoratored) native coroutine tests.")
(license license:expat)))
+(define-public python-pytest-celery
+ (package
+ (name "python-pytest-celery")
+ (version "0.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-celery" version))
+ (sha256
+ (base32 "01pli108qqiiyrn8qsqqabcpazrzj27r7cji9wgglsk76by61l6g"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no tests and circular dependency on python-celery
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'sanity-check)))) ; checks for celery
+ (home-page "https://github.com/graingert/pytest-celery")
+ (synopsis "Shim pytest plugin to enable @code{celery.contrib.pytest}")
+ (description
+ "This package provides a shim Pytest plugin to enable a Celery marker.")
+ (license license:bsd-3)))
+
(define-public python-pytest-env
(package
(name "python-pytest-env")