aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-19 00:29:15 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 00:06:16 +0100
commitd2a65a34d5326397b89e9dc74fb779fd54e55c65 (patch)
tree75afa3623e9c468578f593c4b56efde96cc37d89
parentbe541810ec1a98670c990b97038e1e3bb74299d9 (diff)
downloadguix-d2a65a34d5326397b89e9dc74fb779fd54e55c65.tar
guix-d2a65a34d5326397b89e9dc74fb779fd54e55c65.tar.gz
gnu: Remove python2-kombu.
* gnu/packages/python-xyz.scm (python2-kombu): Remove variable. (python-kombu)[properties]: Remove. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 1 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d06dca68ea..348dd992ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14020,19 +14020,7 @@ and also provide proven and tested solutions to common messaging problems.
AMQP is the Advanced Message Queuing Protocol, an open standard protocol for
message orientation, queuing, routing, reliability and security, for which the
RabbitMQ messaging server is the most popular implementation.")
- (license license:bsd-3)
- (properties `((python2-variant . ,(delay python2-kombu))))))
-
-(define-public python2-kombu
- (let ((kombu (package-with-python2
- (strip-python2-variant python-kombu))))
- (package/inherit kombu
- (arguments `(;; FIXME: 'TestTransport.test_del_sync' fails on python2.
- ;; It works fine on the python3 variant.
- #:tests? #f
- ,@(package-arguments kombu)))
- (native-inputs `(("python2-unittest2" ,python2-unittest2)
- ,@(package-native-inputs kombu))))))
+ (license license:bsd-3)))
(define-public python-billiard
(package