aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-12-26 18:37:44 -0500
committerLeo Famulari <leo@famulari.name>2021-12-26 18:38:11 -0500
commitc9c7b0e1277d378c4948c2db76f27f690ad36db9 (patch)
tree063e73bdeda65e67c7ecf034ead2dc10d4d14f1f
parent4e9895b462a004ac69ee92f544fe39b6c42d8525 (diff)
downloadguix-c9c7b0e1277d378c4948c2db76f27f690ad36db9.tar
guix-c9c7b0e1277d378c4948c2db76f27f690ad36db9.tar.gz
Revert "gnu: Add python-pytest-rerunfailures."
This added a duplicate package definition. This reverts commit 51e26b297cda6fba1a842fbd63732bfa27878748.
-rw-r--r--gnu/packages/python-check.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index d2aa1c328f..a2ac9a201b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1154,34 +1154,6 @@ service processes for your tests with pytest.")
new fixtures, new methods and new comparison objects.")
(license license:expat)))
-(define-public python-pytest-rerunfailures
- (package
- (name "python-pytest-rerunfailures")
- (version "10.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-rerunfailures" version))
- (sha256
- (base32 "15v68kggjvkflbqr0vz8gp5yp3pcsk0rz05bpg2l4xp0a6nin7ly"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest"
- "test_pytest_rerunfailures.py")))))))
- (native-inputs
- (list python-pytest))
- (home-page "https://github.com/pytest-dev/pytest-rerunfailures")
- (synopsis "Pytest plugin to re-run tests to eliminate flaky failures")
- (description "This package provides a Pytest plugin to re-run tests to
-eliminate flaky failures.")
- (license license:mpl2.0)))
-
(define-public python-pytest-aiohttp
(package
(name "python-pytest-aiohttp")