aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-26 01:38:08 +0100
committerMarius Bakke <marius@gnu.org>2021-12-26 23:20:07 +0100
commit9d680229a52f23d146552baff0bc21f63bf5286a (patch)
tree0f5949e9be0e4a61f31eac344616dbe995738402
parent84e6956d2a4c8f5dcb7501713d2681f0a312d848 (diff)
downloadguix-9d680229a52f23d146552baff0bc21f63bf5286a.tar
guix-9d680229a52f23d146552baff0bc21f63bf5286a.tar.gz
gnu: passwordsafe: Adjust style.
* gnu/packages/gnome.scm (passwordsafe)[arguments]: Rewrite as gexp. Avoid referencing the PYTHON variable. Remove trailing #t. [inputs]: Add PYTHON (explicitly).
-rw-r--r--gnu/packages/gnome.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c13d90e019..010b55b092 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10719,23 +10719,22 @@ apply fancy special effects and lets you share the fun with others.")
(base32 "1xh64bbg10gnfzlck5jvqy2zk6hbk9cyqgv85xc9kbdvs8n4lhgh"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t
- #:meson ,meson-0.59
- #:phases
- (modify-phases %standard-phases
- (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref outputs "out")
- "/bin/gnome-passwordsafe"))
- (pylib (string-append (assoc-ref outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages")))
- (wrap-program prog
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
- #t))))))
+ (list #:glib-or-gtk? #t
+ #:meson meson-0.59
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append #$output
+ "/bin/gnome-passwordsafe"))
+ (pylib (string-append
+ #$output "/lib/python"
+ #$(version-major+minor
+ (package-version (this-package-input "python")))
+ "/site-packages")))
+ (wrap-program prog
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))))
(native-inputs
(list desktop-file-utils
gettext-minimal
@@ -10749,6 +10748,7 @@ apply fancy special effects and lets you share the fun with others.")
gtk+
libhandy
libpwquality
+ python
python-pygobject
python-pykeepass))
(home-page "https://gitlab.gnome.org/World/PasswordSafe")