aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-13 14:34:13 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:22 +0100
commit2efabc5589dc641dce75702b99253a3fb40bb2eb (patch)
treec9b04da54c45c13e19b8978369a0cb01245bd99b
parent9e8c6a37dbded0ee721067b4c4066df5f987203a (diff)
downloadguix-2efabc5589dc641dce75702b99253a3fb40bb2eb.tar
guix-2efabc5589dc641dce75702b99253a3fb40bb2eb.tar.gz
gnu: python-numpy-bootstrap, python-numpy: Fix build.
* gnu/packages/python.scm (python-numpy-bootstrap): Correct inputs, use modify-phases, add dummy newlines character to string to make emacs happy, set PYTHONPATH prior to running tests. (python-numpy): propagate inputs, set PYTHONPATH prior to building docs.
-rw-r--r--gnu/packages/python.scm45
1 files changed, 24 insertions, 21 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b160ef5874..092378c1ba 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3098,18 +3098,17 @@ between language specification and implementation aspects.")
(base32
"1bjjhvncraka5s6i4lg644jrxij6bvycxy7an20gcz3a0m11iygp"))))
(build-system python-build-system)
- (native-inputs
- `(("python-nose" ,python-nose)))
(inputs
`(("openblas" ,openblas)
("lapack" ,lapack)))
(native-inputs
- `(("gfortran" ,gfortran)))
+ `(("python-nose" ,python-nose)
+ ("gfortran" ,gfortran)))
(arguments
`(#:phases
- (alist-cons-before
- 'build 'set-environment-variables
- (lambda* (#:key inputs #:allow-other-keys)
+ (modify-phases %standard-phases
+ (add-before 'build 'set-environment-variables
+ (lambda* (#:key inputs #:allow-other-keys)
(call-with-output-file "site.cfg"
(lambda (port)
(format port
@@ -3118,7 +3117,8 @@ libraries = openblas
library_dirs = ~a/lib
include_dirs = ~a/include
-[lapack]
+# backslash-n to make emacs happy
+\n[lapack]
lapack_libs = lapack
library_dirs = ~a/lib
include_dirs = ~a/include
@@ -3131,18 +3131,17 @@ include_dirs = ~a/include
(substitute* "numpy/distutils/system_info.py"
(("c = distutils\\.ccompiler\\.new_compiler\\(\\)")
"c = distutils.ccompiler.new_compiler(); c.set_executables(compiler='gcc',compiler_so='gcc',linker_exe='gcc',linker_so='gcc -shared')"))
- #t)
+ #t))
;; Tests can only be run after the library has been installed and not
;; within the source directory.
- (alist-cons-after
- 'install 'check
- (lambda _
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ ;; Make installed package available for running the tests
+ (add-installed-pythonpath inputs outputs)
(with-directory-excursion "/tmp"
(zero? (system* "python" "-c"
- "import numpy; numpy.test(verbose=2)"))))
- (alist-delete
- 'check
- %standard-phases)))))
+ "import numpy; numpy.test(verbose=2)"))))))))
(home-page "http://www.numpy.org/")
(synopsis "Fundamental package for scientific computing with Python")
(description "NumPy is the fundamental package for scientific computing
@@ -3175,10 +3174,10 @@ capabilities.")
("python2-matplotlib" ,python2-matplotlib)
("python2-pandas" ,python2-pandas)
("python2-scikit-learn" ,python2-scikit-learn)
- ("python2-cython" ,python2-cython)
("python2-pysnptools" ,python2-pysnptools)))
(native-inputs
`(("unzip" ,unzip)
+ ("python2-cython" ,python2-cython)
("python2-mock" ,python2-mock)))
(home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/fastlmm/")
(synopsis "Perform genome-wide association studies on large data sets")
@@ -3193,14 +3192,15 @@ association studies (GWAS) on extremely large data sets.")
(name "python-numpy")
(outputs '("out" "doc"))
(inputs
- `(("which" ,which)
- ("python-matplotlib" ,python-matplotlib)
- ("python-sphinx" ,python-sphinx)
+ `(("which" ,which)))
+ (propagated-inputs
+ `(("python-matplotlib" ,python-matplotlib)
("python-pyparsing" ,python-pyparsing)
- ("python-numpydoc" ,python-numpydoc)
,@(package-inputs python-numpy-bootstrap)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("python-sphinx" ,python-sphinx)
+ ("python-numpydoc" ,python-numpydoc)
("texlive" ,texlive)
("texinfo" ,texinfo)
("perl" ,perl)
@@ -3211,7 +3211,10 @@ association studies (GWAS) on extremely large data sets.")
((#:phases phases)
`(alist-cons-after
'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make installed package available for building the
+ ;; documentation
+ (add-installed-pythonpath inputs outputs)
(let* ((data (string-append (assoc-ref outputs "doc") "/share"))
(doc (string-append
data "/doc/" ,name "-"