aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-12-20 21:42:31 -0500
committerLeo Famulari <leo@famulari.name>2021-12-26 15:52:32 -0500
commit17d7343df82f9865fad5035285976be3000131d4 (patch)
treea3592df31078a1045f4d7185f5c01198c3a6ae2f
parent79fe54052f22a6d96a6cea43b3c4e355ca1da86b (diff)
downloadguix-17d7343df82f9865fad5035285976be3000131d4.tar
guix-17d7343df82f9865fad5035285976be3000131d4.tar.gz
gnu: pypy3: Prohibit references to nss-certs.
Built packages should not refer to nss-certs, to prevent errant hard-coding of a certificate store version. * gnu/packages/python.scm (pypy3)[arguments]: Add nss-certs to #:disallowed-references.
-rw-r--r--gnu/packages/python.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f0d2fd6eb8..23f188c6f9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -780,6 +780,7 @@ ease from the desktop to a microcontroller or embedded system.")
`(#:tests? #f ;FIXME: 43 out of 364 tests are failing
#:modules ((ice-9 ftw) (ice-9 match)
(guix build utils) (guix build gnu-build-system))
+ #:disallowed-references (,nss-certs)
#:phases (modify-phases %standard-phases
(delete 'configure)
(add-after 'unpack 'patch-source