aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:15:21 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:19 +0300
commitdeef6d7c8be5a3216ecf10b49d86e829b9fbf7f4 (patch)
tree00862ef7e1c5263e1245321e8993cdbf49439b07
parentc9efc2295bfdf593275e80b86ea907108ccfa00c (diff)
downloadguix-deef6d7c8be5a3216ecf10b49d86e829b9fbf7f4.tar
guix-deef6d7c8be5a3216ecf10b49d86e829b9fbf7f4.tar.gz
gnu: Add emacs-company-restclient.
* gnu/packages/emacs.scm (emacs-company-restclient): New public variable.
-rw-r--r--gnu/packages/emacs.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c6f8795376..e6429d762a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10221,3 +10221,32 @@ tries to commit changes to a file after every save.
When @code{gac-automatically-push-p} is non-nil, it also tries to push to
the current upstream.")
(license license:gpl3+)))
+
+(define-public emacs-company-restclient
+ (package
+ (name "emacs-company-restclient")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/iquiw/company-restclient/archive/"
+ "v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kr3f0wgqlk7r171bvb2kinv7fanwj2md01wdpx04qkgwcr1as00"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-company" ,emacs-company)
+ ("emacs-know-your-http-well" ,emacs-know-your-http-well)
+ ("emacs-restclient" ,emacs-restclient)))
+ (home-page "https://github.com/iquiw/company-restclient")
+ (synopsis "Company-mode completion back-end for restclient-mode")
+ (description "@code{company-mode} back-end for
+@code{restclient-mode}.
+
+It provides auto-completion for HTTP methods and headers in
+@code{restclient-mode}. Completion source is given by
+@code{know-your-http-well}.")
+ (license license:gpl3+)))