aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-06-08 19:11:24 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-06-08 20:30:29 +0300
commitca82bdfdfbb6d2dae5875158ed418cc823bc5799 (patch)
tree690022d1e0cfcf9d8d7318a0e805d61cfa78abeb
parentcbc1c27b673dc5b7388c2df182bdd0ff7912d98f (diff)
downloadguix-ca82bdfdfbb6d2dae5875158ed418cc823bc5799.tar
guix-ca82bdfdfbb6d2dae5875158ed418cc823bc5799.tar.gz
gnu: twitchy: Install 'rofi-twitchy'.
* gnu/packages/video.scm (twitchy): Install 'rofi-twitchy'.
-rw-r--r--gnu/packages/video.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 51ca1c0ce5..8cd7a3d57c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1865,7 +1865,12 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd)) ;Needs to write to ‘$HOME’.
- #t)))))
+ #t))
+ (add-after 'install 'install-rofi-plugin
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "plugins/rofi-twitchy"
+ (string-append (assoc-ref outputs "out")
+ "/bin")))))))
(inputs
`(("python-requests" ,python-requests)
("streamlink" ,streamlink)))