aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-11 17:31:49 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-11 18:23:24 +0200
commitb63f6c0192cc5cc2f75d2a7dd8ef5371fe8e56b5 (patch)
tree328c1839c8803f735e31ea1129d80ed477bb94be
parent4d65c1c304e1a290a70f397684ae8cd43d286036 (diff)
downloadguix-b63f6c0192cc5cc2f75d2a7dd8ef5371fe8e56b5.tar
guix-b63f6c0192cc5cc2f75d2a7dd8ef5371fe8e56b5.tar.gz
gnu: python2: Deprecate "python@2".
* gnu/packages/python.scm (python2-called-python): New variable.
-rw-r--r--gnu/packages/python.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b41e0c61b8..3907fd66bd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -341,6 +341,15 @@ data types.")
;; Current 2.x version.
(define-public python-2 python-2.7)
+(define-public python2-called-python
+ ;; Both 2.x and 3.x used to be called "python". In commit
+ ;; a7714d42de2c3082f3609d1e63c83d703fb39cf9 (March 2018), we renamed the
+ ;; Python 2.x package to "python2".
+ (package
+ (inherit python-2)
+ (name "python")
+ (properties `((superseded . ,python-2)))))
+
(define-public python-3.6
(package (inherit python-2)
(name "python")